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10/5/04 Meeting Highlights

Ten CDEMS users from 6 Washington clinics attended the CDEMS User Support Meeting in Toppenish, WA on October 5, 2004. Participants were: Heidi Martinez & Liza Jasso (Yakima Valley Farm Worker’s Clinic), Susie Bowles (Pomeroy Medical Clinic), Laura Upton Welch (Darrington Clinic), Linda Pelland and Crystal O’Brien (North Bend Family Clinic), Pam Johnson, Jill Bradwell, & Candace Newkirk (Family Practice Clinic – Goldendale), Becky Petty (Skyline Hospital), Dusty Knobel & Jackie Gianunzio (CDEMS Support).

CDEMS implementation and customizations were the main discussion topics for the meeting.  Common maintenance issues were reviewed in a short CDEMS demonstration. Much interactive discussion followed the presentations, and four key topics are documented below.
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Discussion Topics

User Presentation:  CDEMS Implementation at Yakima Valley Farm Worker’s Clinic – Yakima

Heidi Martinez, Chronic Care Database Specialist at the Yakima Valley Farm Worker’s Clinic (YVFWC), presented the CDEMS implementation process and registry customizations made during the past year at the Yakima clinic.  Automatic non-HDL calculation, tracking hospitalizations in CDEMS for WA State Collaborative pilot group, data fixes, limitations of self-management goal documentation, dietitian clinic setup, and EMR integration with CDEMS were discussed.

The group discussed the process for handling CDEMS form updates and customizations.  A chronic care team determines progress note form content at YVFWC.  Heidi demonstrated a customization she made to relocate the BMI information box to left side of form and shade the cell pink for emphasis.

The issue of goal lines automatically adjusting with graph scales was a concern with another CDEMS customization.  The goal line shifts automatically as the graph scale changes and inaccurately repositions to accommodate extremely high values.  Dusty states that it may not be possible to use target goal lines because of this auto scale feature.

The impact of timing of printing the progress note on the CDEMS tickler system was discussed at length.  If the progress note is not printed close to the time of a patient visit, Dusty pointed out that the use of the tickler would not be a reliable system for reminders.  Reminders are calculated from the date the progress note is printed – if the note is printed a month or two prior to a patient visit, tickler reminders are no longer timely and should probably be disabled.  The difficulty of printing notes right before a visit, for no-shows, or for non-scheduled visits are factors impacting when the progress note is printed and placed in the chart.

Liza Jasso described in detail the use of Advanced Access for scheduling appointments and linking to Practice Point to generate recall and reminder notices at the Grandview Yakima Valley Farm Worker’s Clinic. 
Below are resource links for further diabetes information or products mentioned during the meeting:   

· A self-management contract for documenting goals and other self-management support tools are available at: http://www.doh.wa.gov/cfh/WSC/Model_Info/Self_Management_Support/SMSpage1.htm
· Free diabetes information handouts are available from the National Diabetes Information Clearinghouse web site:  http://www.diabetes.niddk.nih.gov


· The Washington Diabetes Prevention & Control Program has free diabetes handouts, gifts and information about coalition formation.  Contact Sara Sarliker at sara.sarliker@doh.wa.gov or call (360) 236-3963 for more information about these resources.
CDEMS Maintenance Demo 

· Database Backup.  Think about it -- how much data would you be comfortable losing?  Back up your cdem_dta.mdb file often!  Verify that your cdem_dta.mdb file is part of the server backup if CDEMS is installed on a network.  Never assume that the CDEMS files are included in the network backup!

Follow the steps below for backing up your CDEMS data file:


1. Label & date backup medium (floppy, CD or Zip) before inserting into the appropriate drive 

2. Navigate to the cdem_dta.mdb file in the CDEMS folder on your computer 

3. Right click on the file cdem_dta.mdb 

4. Click Send to and select your backup medium - floppy, zip drive, CD 

5. Make back up copies of CDEMS Data Entry (cdem_8-8-03.mdb) and Report (rpt_7-14-04.mdb) programs if you've made customizations worth protecting.

Tip: Rename your backup file on the floppy, CD or Zip drive to include the date the copy was made (for example: copy_cdem_dta_100504.mdb).  This helps identify the most recent backup file in the unfortunate event your data must be recovered.  It also prevents writing over backup files you may have made previously.

If your database becomes too large to fit on a floppy, it will have to first be zipped or condensed before copying to the floppy.  Compacting and repairing the database, described below, will also reduce the size of the database significantly.

· Compact & Repair the cdem_dta.mdb file to improve performance and conserve disk space.  The more activity that occurs in the database, the more frequently this operation should be performed. Also periodically compact & repair CDEMS Data Entry and Reports program files as customizations are made.  It's recommended to backup the cdem_dta.mdb file before compacting & repairing, particularly if you think the database may be damaged.

Instructions for compacting & repairing the CDEMS database:

1. Open cdem_dta.mdb file directly

2. Click Tools in menu bar > Click Database Utilities

3. If using Access 2k version, click Compact & Repair Database.
If using Access 97 version, compact and repair database are separate operations -- compact first, then repair.

4. Close cdem_dta.mdb file

Tip: "Compact on Close" - It's possible to set your database to automatically compact on closing (if the size will be reduced by at least 256KB).  Here's how:

1. Open the cdem_dta.mdb file > Click Tools > Options

2. Click the General tab of the Options box

3. Click the Compact on Close check box
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1. Start by making a backup copy of your cdem_dta.mdb file. Edits made at the table level are saved instantly and there is no "undo" function.  If you make a mistake, it's a good idea to have a backup file handy.

2. Open the CDEMS Data Entry Program (cdem_8-8-03)

3. Press F11 to work in database view 

4. Click on Tables > double-click on tblDemo 

5. Right click on PCP column heading > Sort Ascending (this groups the provider entries together for easier editing) 

6. Decide on a single name for each provider.  You'll use this identical name in the provider entries in tblDemo and in the PCP dropdown list. 

7. Place the cursor in a PCP cell that you would like to change (for example, Blackburn) 

8. Click on Edit in the menu bar at top of screen > Replace 

9. Type "Blackburn" in the Find What box > type "Blackburn, Bill " in the Replace With box

10. Click Replace All (this will replace all PCP = "Blackburn" with the "Blackburn, Bill" PCP name) > click Yes to replace all 

11. Repeat steps 7-10 for each PCP entry that needs to be changed

12. Before closing the table, sort the PCP column ascending to verify all provider changes have been made. 

13. Close tblDemo; do not save changes to design of this table

14. Double-click on tlkpPCP 

15. Click on the gray shaded cell along the left margin to select the row for each PCP name you want to delete (for example, Blackburn) > click Edit in menu bar > Delete Record (this will eliminate the PCP name from your data entry dropdown list) 

16. Repeat step 14 for each PCP name you wish to remove from the dropdown list 

17. Close tlkpPCP

· Ethnicity list/data cleanup.  Because you cannot delete anything in a table that is being used in a patient record, you'll need to go into tblDemo and manually change the ethnicities. Follow the steps below to clean up these records... 


1. Start by making a backup copy of your cdem_dta.mdb file (just in case you need to restore your original file)

2. Open the CDEMS Data Entry Program (cdem_8-8-03) 

3. Press F11 to work in database view 

4. Click on Tables > double-click on tblDemo 

5. Right click on Ethnicity column heading > Sort Ascending (this groups the ethnicity entries together alphabetically)

6. Decide on a single ethnic name for each group you want to track in CDEMS. 

IMPORTANT NOTE: The Diabetes Summary Report is pre-coded to count ethnic groups classified as Am Indian, Asian, Black, Hispanic, Pacific Islander, Unknown and White.  If you decide to classify "White" patients as "Caucasian", they will no longer be accurately counted in this pre-coded summary report.  The Create-A-Report function references unique ethnicity groups actually entered into CDEMS to summarize those unique to your clinic.


7. Place the cursor in an ethnicity cell that you would like to change (for example, Caucasian) 

8. Click on Edit in the menu bar at top of screen > Replace 

9. Type "Caucasian" in the Find What box > type "White" in the Replace With box 

10. Click Replace All (this will replace all ethnicities = "Caucasian" with the "White" ethnicity name) 

11. Repeat steps 7-9 for each ethnicity entry that needs to be changed 

12. Close tblDemo; do not save changes to design of this table 

13. Double-click on tlkpEthnicity

14. Click on the shaded box along the left margin to select the row for each ethnic name you want to delete (for example, Caucasian) > click Edit in menu bar > Delete Record (this will eliminate the ethnicity name from your data entry dropdown list)

15. Repeat step 14 for each ethnic name you wish to remove from the dropdown list 

16. Close tlkpEthnicity

· Telephone format cleanup.  After conversion from DEMS to CDEMS or after editing a phone number directly in tblDemo, the format for patient telephone numbers may become garbled looking something like this: (206)()4-78 3563.  Cleaning up the phone number field is a bit more complicated than the cleanup of other CDEMS fields.  The desired format for phone numbers in CDEMS is straight numbers without spaces, parentheses, or dashes.  CDEMS automatically formats the phone fields for you.  Carefully follow the instructions below to clean up garbled phone numbers... 

1. Because global table changes are made during the phone number cleanup, it’s ESSENTIAL to backup the cdem_dta.mdb file before beginning.  It’s easy to make a mistake, changes are instantaneous, and there’s no easy option to undo changes other than restoring the original data file.

2. Locate the CDEM data file in your CDEMS folder. Double-click on cdem_dta.mdb file to open 

3. Click on Tables > double-click on tblDemo 

4. Click on View in upper menu bar > Design view 

5. Place cursor in phone1 Field Name in the upper portion of the window 

6. Delete Format and Input Mask entries in Field Properties box in lower half of screen 

7. Click View > Datasheet View > Save changes 

8. Scroll over to the phone1 column 

9. Click on a garbled telephone number cell to be modified > click Edit in menu bar > Replace 

10. Enter first value to delete in the “Find What” box (for example, to remove a left parenthesis, type "(" in the Find What box)

Note: phone number entries in CDEMS should be numbers only, (e.g. 8004783563) without extraneous parentheses or dashes. Proper formatting is applied automatically when displayed. 


11. Leave the “Replace With” box blank

12. Look In box should be "phone1" 

13. Match box should be "Any Part of Field" 

14. Click Replace All > you’ll see a strong message “You won’t be able to undo this replace operation.” > Click Yes to continue 

15. Continue the Replace loop (steps 10-14) until all parentheses and dashes are removed

16. Click on phone1 column heading > Sort Descending 

17. Scan the phone1 list and remove any unwanted spaces or other minor changes to the phone numbers 

18. Next, restore the CDEMS formatting specifications that were removed in Step 6. Click View > Design View 

19. Click on phone2 

20. Copy formatting in Field Properties box for phone2 [@@@)@@@-@@@@] 

21. Click on phone1 > place cursor in empty Format box > Paste format copied from phone2 

22. Again, click on phone2 

23. Copy formatting in Input Mask box for phone2 [!\(999") "000\-0000;0;x] 

24. Click on phone1 > place cursor in empty Input Mask box > Paste input mask format copied from phone2 

25. Click View > Datasheet View to review changes > SAVE table changes 

26. Close tblDemo

Information/Q & A Responses

Question #1 — How can other vitals beyond weight and BP be recorded on the CDEMS progress note?

Vitals such as pulse and temperature are not stored in CDEMS, but it’s easy to create a prompt for providers to collect these vitals by adding SOAP prompts in a customized version of the progress note.  Here’s how:

1. Preview a patient in the Data Entry program > click View > Design View

2. Click View > Toolbox to open toolbox > select Aa icon (label) from Toolbox

3. Size and place label in desired location on form.  Position label in area where the labs and services section of the form will not auto expand into.  This customization fits best on the CDEMS Style 1 progress note (frmPN1)…and safest spot for the label is below the “New Note” area of the progress note.

Type prompts for desired vitals within the label box -- remember that vitals are not entered or stored in CDEMS, but merely documented on the form.

4. Click File > Save to save form changes 

5. Preview the modified form for a patient (see sample below)


Question #2 — How can I get around the constraints for adding multiple objects to the CDEMS progress note?

Microsoft Access, your version of Windows, your computer and CDEMS all have limitations as to what can be changed or customized on CDEMS forms.  Access has a limit of 750 items (textboxes, labels, graphs, etc.) that can be displayed on a form.  The progress note is close to this limit so you may quickly exceed the capacity of the form by adding a large number of items.  Here’s a work-around tip for maximizing the number of items on a form without exceeding the Access limitation:  build objects containing multiple items in Word or Paint and paste into the CDEMS form as a single object. 

Question #3 ​— I need to expand the PCP field length to display the full provider name on the progress note.

The default PCP field length is 17 characters.  To accommodate longer names, follow the instructions below to increase both the field size and the text display area on the progress note:

1. Open Data Entry program > click on Entry tab

2. Click “Add New Patient” > once form is displayed on screen, click View > Design View

3. Right-click in PCP unbound box > Properties

4. Scroll down to “After Update” Event Procedure  > click in Event Procedure box > click on ellipses (…) that appear to the right of this box

5. Replace “17” in the code segment shown below with a “50” to change the PCP field length to 50 characters – type only the “50” in red in the lines of SQL code shown below:

================================================

Private Sub cboNP_PCP_AfterUpdate()
'Converts first letter of first name to upper case -
cboNP_PCP = UCase(Left(cboNP_PCP, 1)) & Mid(cboNP_PCP, 2, 50)


End Sub

================================================


6. Click File > Save

7. Click on X in Microsoft Visual Basic window to close

8. Click on X in Combo Box: cboNP_PCP to close

9. Click on X in frmNewPatient: Form to close

10. Select a patient and click Print Preview > click View > Design View

11. Carefully expand the size of the PCP text box to fit your longest PCP name – it may be necessary to reduce the font size or move other label and text boxes around to accommodate this.  It’s best to select the box (or hold shift key down to select multiple boxes) and use the arrow keys to keep boxes properly aligned while moving them.  If space is very tight, consider changing the PCP font to Arial Narrow to squeeze in longer names.

12. Click View > Form View to preview the change

13. Return to View > Design View to make further adjustments; when satisfied, click File > Save to save changes to the form

Question #4 — Please tell me the steps to mail merge addresses from CDEMS to create mailing labels!
Mailing labels can be printed using the mail merge feature of Microsoft Word and the CDEMS registry database.  Keep in mind that the instructions for accomplishing this task may be slightly different than described below, depending on your versions of Access and Windows.

1. Run your query or open the desired table in the CDEMS Reports program.
From the resulting table, click Tools > Office Links >
Merge It with MS Word > Create a new document and then link the data to it

[If you’ve previously created a mailing label template, Merge It with MS Word > Link your data to an existing Microsoft Word document]

2. Word will open with a blank document.  Select Tools > Mail Merge

Main Document > Create > Mailing Labels > Active Window

[Once you have created the mailing label template, open the template when Word opens, then perform steps 3a and 3b only before going to step 4.]

3. Data Source

a. Click Get Data > Open Data Source
At bottom of data source window set Files of Type = MS Access databases
 

b. Look In: double-click on the current CDEMS Reports program in the CDEMS folder
(Rpts_7-14-04.mdb)
Select desired Table or Query (the one you ran in step 1):
Example1:   "Qry_ListPatientWithCondition” 
Click the box to link to query >  "link to query" > OK

c. Click Set up Main Document > select label type from list (usually #5160 Avery) > OK
· Enter (blank row)

· Insert Merge Fields > First name > space > Insert Merge Fields > Last Name > enter

· Insert Merge Fields > Address1 > enter

· Insert Merge Fields > Address2 > enter

· Insert Merge Fields > City > space > Insert Merge Fields > State > space > Insert Merge Fields > Zip

The main document, the template should look like this:

First name Last name

Address 1

Address 2

City, State Zip


d. Save As “Mailing Label template.doc” in your CDEMS folder

4. Merge Data

a. To New Document > All
b. Merge

c. Optional ~

· To insure that a printer blip does not destroy your labels before printing is completed, save your labels in a temp file before sending to printer.

· Alignment test:  Before printing labels, check proper alignment by printing only the first page on regular paper.  Overlay that printed page with the label sheet to check alignment.  If not aligned properly, return to Set Up Main Document in Step 2 and adjust by inserting or deleting a blank line before inserting merge fields.

d. Print labels!

The meeting concluded with a two and one-half hour Reports training session.  Thank you to Heidi Martinez for assisting with arrangements and presenting at this User Meeting.  And thanks to the Yakima Valley Farm Worker’s Clinic at Toppenish for sharing their fine facilities to host the meeting!  Attendees enthusiastically suggested that periodic User Support meetings be held in central Washington.

Next User Support Meeting:  December 9, 2004 in Kent, WA
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